Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. langflow
  4. ›
  5. CVE-2026-7700

CVE-2026-7700: Langflow: Prompt injection in Langflow Smart Transform can lead to code execution

October 5, 2026

Langflow versions 1.3.0 through 1.10.2 contain a code-injection vulnerability in the Smart Transform (LambdaFilterComponent) component.

Smart Transform places flow-author instructions and a preview of its input data into a prompt asking an LLM to generate a Python lambda. It then extracts a one-line lambda from the model response, applies only syntactic format checks, evaluates it with Python’s full builtins, and invokes the resulting function inside the Langflow process.

A malicious flow author can exploit this directly through the Instructions field. In deployments where an exposed flow passes attacker-controlled content into Smart Transform, an attacker may also exploit it indirectly through prompt injection, subject to the configured model following the injected instruction.

References

  • github.com/advisories/GHSA-9fpm-3445-2vx4
  • github.com/langflow-ai/langflow/commit/1641b28f33e2c47b9a0c6855922d44d1b8418b9d
  • github.com/langflow-ai/langflow/commit/94859df33acd70b2a1f816e26d68f5e89a7e5639
  • github.com/langflow-ai/langflow/pull/13530
  • github.com/langflow-ai/langflow/releases/tag/v1.10.3
  • github.com/langflow-ai/langflow/security/advisories/GHSA-9fpm-3445-2vx4
  • nvd.nist.gov/vuln/detail/CVE-2026-7700
  • vuldb.com/submit/804305
  • vuldb.com/vuln/360869
  • www.yuque.com/mengnanbulalei/ognlsk/hte2a98ro5gf8tp9?singleDoc

Code Behaviors & Features

Detect and mitigate CVE-2026-7700 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.3.0 before 1.10.3

Fixed versions

  • 1.10.3

Solution

Upgrade to version 1.10.3 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/langflow/CVE-2026-7700.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:54 +0000.