Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. langflow
  4. ›
  5. CVE-2025-57760

CVE-2025-57760: Langflow Vulnerable to Privilege Escalation via CLI Superuser Creation (Post-RCE)

August 25, 2025 (updated December 18, 2025)

A privilege escalation vulnerability exists in Langflow containers where an authenticated user with RCE access can invoke the internal CLI command langflow superuser to create a new administrative user. This results in full superuser access, even if the user initially registered through the UI as a regular (non-admin) account.

References

  • github.com/advisories/GHSA-4gv9-mp8m-592r
  • github.com/langflow-ai/langflow
  • github.com/langflow-ai/langflow/commit/c188ec113c9ca46154ad01d0eded1754cc6bef97
  • github.com/langflow-ai/langflow/pull/9152
  • github.com/langflow-ai/langflow/security/advisories/GHSA-4gv9-mp8m-592r
  • nvd.nist.gov/vuln/detail/CVE-2025-57760

Code Behaviors & Features

Detect and mitigate CVE-2025-57760 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.5.1

Fixed versions

  • 1.5.1

Solution

Upgrade to version 1.5.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

pypi/langflow/CVE-2025-57760.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:05 +0000.