Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. langflow
  4. ›
  5. CVE-2024-37014

CVE-2024-37014: Langflow remote code execution vulnerability

June 10, 2024 (updated January 21, 2025)

Langflow allows remote code execution if untrusted users are able to reach the “POST /api/v1/custom_component” endpoint and provide a Python script.

References

  • github.com/advisories/GHSA-qg33-x2c5-6p44
  • github.com/langflow-ai/langflow
  • github.com/langflow-ai/langflow/issues/1973
  • github.com/pypa/advisory-database/tree/main/vulns/langflow/PYSEC-2024-177.yaml
  • nvd.nist.gov/vuln/detail/CVE-2024-37014

Code Behaviors & Features

Detect and mitigate CVE-2024-37014 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.0.15

Fixed versions

  • 1.0.15

Solution

Upgrade to version 1.0.15 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-913: Improper Control of Dynamically-Managed Code Resources
  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/langflow/CVE-2024-37014.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:58 +0000.