Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. langchain
  4. ›
  5. CVE-2023-39659

CVE-2023-39659: LangChain vulnerable to arbitrary code execution

August 15, 2023 (updated September 27, 2024)

An issue in langchain langchain-ai before version 0.0.325 allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component.

References

  • github.com/advisories/GHSA-prgp-w7vf-ch62
  • github.com/langchain-ai/langchain
  • github.com/langchain-ai/langchain/commit/cadfce295f8a33828fc635c2e5ea28b883e5c992
  • github.com/langchain-ai/langchain/issues/7700
  • github.com/langchain-ai/langchain/pull/12427
  • github.com/langchain-ai/langchain/pull/5640
  • github.com/langchain-ai/langchain/releases/tag/v0.0.325
  • github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-147.yaml
  • nvd.nist.gov/vuln/detail/CVE-2023-39659

Code Behaviors & Features

Detect and mitigate CVE-2023-39659 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.0.325

Fixed versions

  • 0.0.325

Solution

Upgrade to version 0.0.325 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

Source file

pypi/langchain/CVE-2023-39659.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.