Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. langchain
  4. ›
  5. CVE-2023-38860

CVE-2023-38860: LangChain vulnerable to arbitrary code execution

August 15, 2023 (updated September 27, 2024)

An issue in LangChain prior to v.0.0.247 allows a remote attacker to execute arbitrary code via the prompt parameter.

References

  • github.com/advisories/GHSA-fj32-q626-pjjc
  • github.com/hwchase17/langchain
  • github.com/hwchase17/langchain/issues/7641
  • github.com/langchain-ai/langchain/commit/d353d668e4b0514122a443cef91de7f76fea4245
  • github.com/langchain-ai/langchain/commit/fab24457bcf8ede882abd11419769c92bc4e7751
  • github.com/langchain-ai/langchain/issues/7641
  • github.com/langchain-ai/langchain/pull/8092
  • github.com/langchain-ai/langchain/pull/8425
  • github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-145.yaml
  • nvd.nist.gov/vuln/detail/CVE-2023-38860

Code Behaviors & Features

Detect and mitigate CVE-2023-38860 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.0.247

Fixed versions

  • 0.0.247

Solution

Upgrade to version 0.0.247 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/langchain/CVE-2023-38860.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:23 +0000.