Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. langchain
  4. ›
  5. CVE-2023-34541

CVE-2023-34541: Langchain vulnerable to arbitrary code execution

June 20, 2023 (updated September 27, 2024)

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

References

  • github.com/advisories/GHSA-6643-h7h5-x9wh
  • github.com/langchain-ai/langchain
  • github.com/langchain-ai/langchain/commit/fab24457bcf8ede882abd11419769c92bc4e7751
  • github.com/langchain-ai/langchain/issues/4849
  • github.com/langchain-ai/langchain/issues/4849
  • github.com/langchain-ai/langchain/pull/8425
  • github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-92.yaml
  • nvd.nist.gov/vuln/detail/CVE-2023-34541

Code Behaviors & Features

Detect and mitigate CVE-2023-34541 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.0.247

Fixed versions

  • 0.0.247

Solution

Upgrade to version 0.0.247 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

pypi/langchain/CVE-2023-34541.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:55 +0000.