Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. keystone
  4. ›
  5. CVE-2019-19687

CVE-2019-19687: OpenStack Keystone Credential Leakage

May 24, 2022 (updated September 27, 2024)

OpenStack Keystone 15.0.0 and 16.0.0 is affected by Data Leakage in the list credentials API. Any user with a role on a project is able to list any credentials with the /v3/credentials API when enforce_scope is false. Users with a role on a project are able to view any other users’ credentials, which could (for example) leak sign-on information for Time-based One Time Passwords (TOTP). Deployments with enforce_scope set to false are affected. (There will be a slight performance impact for the list credentials API once this issue is fixed.)

References

  • access.redhat.com/errata/RHSA-2019:4358
  • bugs.launchpad.net/keystone/+bug/1855080
  • bugzilla.redhat.com/show_bug.cgi?id=1781470
  • git.openstack.org/cgit/openstack/keystone/commit/?id=17947516b0095c51da5cff94771247f2e7c44ee6
  • git.openstack.org/cgit/openstack/keystone/commit/?id=17c337dbdbfb9d548ad531c2ad0483c9bce5b98f
  • git.openstack.org/cgit/openstack/keystone/commit/?id=bd3f63787151183f4daa43578aa491856fefae5b
  • github.com/advisories/GHSA-2j23-fwqm-mgwr
  • github.com/openstack/keystone
  • github.com/openstack/keystone/commit/17947516b0095c51da5cff94771247f2e7c44ee6
  • github.com/openstack/keystone/commit/17c337dbdbfb9d548ad531c2ad0483c9bce5b98f
  • github.com/openstack/keystone/commit/bd3f63787151183f4daa43578aa491856fefae5b
  • github.com/pypa/advisory-database/tree/main/vulns/keystone/PYSEC-2019-29.yaml
  • nvd.nist.gov/vuln/detail/CVE-2019-19687
  • review.opendev.org/
  • review.opendev.org/
  • review.opendev.org/
  • security.openstack.org/ossa/OSSA-2019-006.html
  • usn.ubuntu.com/4262-1

Code Behaviors & Features

Detect and mitigate CVE-2019-19687 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 15.0.0 before 15.0.1, version 15.0.0, all versions starting from 16.0.0 before 16.0.1, version 16.0.0

Fixed versions

  • 15.0.1
  • 16.0.1

Solution

Upgrade to versions 15.0.1, 16.0.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

pypi/keystone/CVE-2019-19687.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.