Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. keylime
  4. ›
  5. CVE-2025-1057

CVE-2025-1057: Keylime registrar is vulnerable to Denial-of-Service attack when updated to version 7.12.0

February 14, 2025 (updated July 21, 2026)

The Keylime registrar implemented more strict type checking on version 7.12.0. As a result, when updated to version 7.12.0, the registrar will not accept the format of the data previously stored in the database by versions >= 7.8.0, raising an exception.

This makes the Keylime registrar vulnerable to a Denial-of-Service attack in an update scenario, as an attacker could populate the registrar database by creating multiple valid agent registrations with different UUIDs while the version is still < 7.12.0. Then, when the Keylime registrar is updated to the 7.12.0 version, any query to the database matching any of the entries populated by the attacker will result in failure.

References

  • access.redhat.com/security/cve/CVE-2025-1057
  • bugzilla.redhat.com/show_bug.cgi?id=2343894
  • github.com/advisories/GHSA-9jxq-5x44-gx23
  • github.com/ansasaki/keylime/tree/base64_bytes
  • github.com/keylime/keylime
  • github.com/keylime/keylime/commit/e08b10d86c3717006774e787542c190e2ba24fc7
  • github.com/keylime/keylime/security/advisories/GHSA-9jxq-5x44-gx23
  • github.com/keylime/rust-keylime
  • github.com/pypa/advisory-database/tree/main/vulns/keylime/PYSEC-2026-1488.yaml
  • nvd.nist.gov/vuln/detail/CVE-2025-1057
  • pypi.org/project/keylime

Code Behaviors & Features

Detect and mitigate CVE-2025-1057 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 7.12.0 before 7.12.1

Fixed versions

  • 7.12.1

Solution

Upgrade to version 7.12.1 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-1287: Improper Validation of Specified Type of Input
  • CWE-704: Incorrect Type Conversion or Cast

Source file

pypi/keylime/CVE-2025-1057.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:20 +0000.