Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. keras
  4. ›
  5. CVE-2025-49655

CVE-2025-49655: Keras framework vulnerable to deserialization of untrusted data

October 17, 2025 (updated October 27, 2026)

Deserialization of untrusted data can occur in versions of the Keras framework running versions 3.11.0 up to but not including 3.11.3, enabling a maliciously uploaded Keras file containing a TorchModuleWrapper class to run arbitrary code on an end user’s system when loaded despite safe mode being enabled. The vulnerability can be triggered through both local and remote files.

References

  • github.com/advisories/GHSA-cvhh-q5g5-qprp
  • github.com/keras-team/keras/pull/21575
  • github.com/pypa/advisory-database/tree/main/vulns/keras/PYSEC-2026-368.yaml
  • hiddenlayer.com/sai_security_advisor/2025-10-keras
  • nvd.nist.gov/vuln/detail/CVE-2025-49655
  • pypi.org/project/keras

Code Behaviors & Features

Detect and mitigate CVE-2025-49655 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.11.0 before 3.11.3

Fixed versions

  • 3.11.3

Solution

Upgrade to version 3.11.3 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

pypi/keras/CVE-2025-49655.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:53 +0000.