Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. kdcproxy
  4. ›
  5. CVE-2015-5159

CVE-2015-5159: Improper Input Validation in kdcproxy

November 1, 2018 (updated September 24, 2024)

python-kdcproxy before 0.3.2 allows remote attackers to cause a denial of service via a large POST request.

References

  • bugzilla.redhat.com/show_bug.cgi?id=1245200
  • github.com/advisories/GHSA-j7c4-2xj8-wm7r
  • github.com/latchset/kdcproxy
  • github.com/latchset/kdcproxy/commit/f274aa6787cb8b3ec1cc12c440a56665b7231882
  • github.com/pypa/advisory-database/tree/main/vulns/kdcproxy/PYSEC-2018-85.yaml
  • nvd.nist.gov/vuln/detail/CVE-2015-5159

Code Behaviors & Features

Detect and mitigate CVE-2015-5159 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.3.2

Fixed versions

  • 0.3.2

Solution

Upgrade to version 0.3.2 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/kdcproxy/CVE-2015-5159.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.