Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. jupyterlab
  4. ›
  5. GHSA-89vp-jrxv-24w8

GHSA-89vp-jrxv-24w8: JupyterLab: PyPI extension blocklist package-name canonicalization bypass

July 22, 2026 (updated August 12, 2026)

JupyterLab’s PyPI extension manager enforces blocked_extensions_uris by comparing the requested install name to blocklist entries with a custom string normalization that is weaker than PyPI package-name canonicalization. An authenticated user can request a PyPI-equivalent spelling such as JupyterLab.Git for a blocklisted package such as jupyterlab-git; JupyterLab accepts the install request even though pip resolves the variant to the same package.

This has security implications only for deployments that combine all of the following:

  • an allowlist/blocklist configured with the intent of restricting which packages users can install;
  • the (default) PyPI Extension Manager enabled; and
  • kernels and terminals disabled or delegated to remote hosts (otherwise a user with kernel access can install packages directly regardless of this check)

References

  • github.com/advisories/GHSA-89vp-jrxv-24w8
  • github.com/jupyterlab/jupyterlab/commit/be9303f5bcd5308eaeae953c5a3c903046682c2c
  • github.com/jupyterlab/jupyterlab/commit/f1beab4a2027af4719d6edc07d52d6cf5a39a432
  • github.com/jupyterlab/jupyterlab/pull/19184
  • github.com/jupyterlab/jupyterlab/pull/19185
  • github.com/jupyterlab/jupyterlab/pull/19186
  • github.com/jupyterlab/jupyterlab/releases/tag/v4.5.10
  • github.com/jupyterlab/jupyterlab/releases/tag/v4.6.2
  • github.com/jupyterlab/jupyterlab/security/advisories/GHSA-89vp-jrxv-24w8
  • nvd.nist.gov/vuln/detail/CVE-2026-73416

Code Behaviors & Features

Detect and mitigate GHSA-89vp-jrxv-24w8 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.5.0 before 4.5.10, all versions starting from 4.6.0 before 4.6.2

Fixed versions

  • 4.5.10
  • 4.6.2

Solution

Upgrade to versions 4.5.10, 4.6.2 or above.

Impact 7.6 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L

Learn more about CVSS

Weakness

  • CWE-178: Improper Handling of Case Sensitivity
  • CWE-180: Incorrect Behavior Order: Validate Before Canonicalize

Source file

pypi/jupyterlab/GHSA-89vp-jrxv-24w8.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:53 +0000.