Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. jupyterlab
  4. ›
  5. CVE-2026-42266

CVE-2026-42266: JupyterLab has an Extension Manager API/GUI Policy Discrepancy, allowing 3rd party (malicious) extensions install via POST request

May 5, 2026 (updated June 8, 2026)

The allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab prior to 4.5.7. The PyPI Extension Manager was not contained to packages listed on the default PyPI index.

This has security implications for deployments that:

  • have allow-listed specific extensions with aim to prevent users from installing packages
  • have the kernel and terminals disabled or delegated to remote hosts (thus no access to install packages in the single-user server environment)
  • have multi-tenant deployments that is not configured for untrusted users (as per documented on JupyterHub https://jupyterhub.readthedocs.io/en/5.2.1/explanation/websecurity.html)
  • have the (default) PyPI Extension Manager enabled

References

  • github.com/advisories/GHSA-37w4-hwhx-4rc4
  • github.com/jupyterlab/jupyterlab/releases/tag/v4.5.7
  • github.com/jupyterlab/jupyterlab/security/advisories/GHSA-37w4-hwhx-4rc4
  • github.com/pypa/advisory-database/tree/main/vulns/jupyterlab/PYSEC-2026-164.yaml
  • jupyterhub.readthedocs.io/en/5.2.1/explanation/websecurity.html
  • jupyterlab.readthedocs.io/en/latest/user/extensions.html
  • nvd.nist.gov/vuln/detail/CVE-2026-42266

Code Behaviors & Features

Detect and mitigate CVE-2026-42266 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0.0 before 4.5.7

Fixed versions

  • 4.5.7

Solution

Upgrade to version 4.5.7 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation
  • CWE-602: Client-Side Enforcement of Server-Side Security
  • CWE-88: Improper Neutralization of Argument Delimiters in a Command ('Argument Injection')

Source file

pypi/jupyterlab/CVE-2026-42266.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:05 +0000.