Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. jupyterhub
  4. ›
  5. CVE-2024-41942

CVE-2024-41942: JupyterHub has a privilege escalation vulnerability with the `admin:users` scope

August 8, 2024 (updated January 21, 2025)

If a user is granted the admin:users scope, they may escalate their own privileges by making themselves a full admin user.

References

  • github.com/advisories/GHSA-9x4q-3gxw-849f
  • github.com/jupyterhub/jupyterhub
  • github.com/jupyterhub/jupyterhub/commit/99e2720b0fc626cbeeca3c6337f917fdacfaa428
  • github.com/jupyterhub/jupyterhub/commit/ff2db557a85b6980f90c3158634bf924063ab8ba
  • github.com/jupyterhub/jupyterhub/security/advisories/GHSA-9x4q-3gxw-849f
  • github.com/pypa/advisory-database/tree/main/vulns/jupyterhub/PYSEC-2024-200.yaml
  • nvd.nist.gov/vuln/detail/CVE-2024-41942

Code Behaviors & Features

Detect and mitigate CVE-2024-41942 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.1.6, all versions starting from 5.0.0 before 5.1.0

Fixed versions

  • 4.1.6
  • 5.1.0

Solution

Upgrade to versions 4.1.6, 5.1.0 or above.

Impact 7.2 HIGH

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-274: Improper Handling of Insufficient Privileges

Source file

pypi/jupyterhub/CVE-2024-41942.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.