Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ironic
  4. ›
  5. CVE-2026-42510

CVE-2026-42510: OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere

April 28, 2026 (updated July 8, 2026)

OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.

References

  • bugs.launchpad.net/ironic/+bug/2148331
  • github.com/advisories/GHSA-wqpv-c3pp-3m58
  • nvd.nist.gov/vuln/detail/CVE-2026-42510
  • security.openstack.org/ossa/OSSA-2026-008.html

Code Behaviors & Features

Detect and mitigate CVE-2026-42510 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 35.0.1

Fixed versions

  • 35.0.1

Solution

Upgrade to version 35.0.1 or above.

Impact 6.6 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-829: Inclusion of Functionality from Untrusted Control Sphere

Source file

pypi/ironic/CVE-2026-42510.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:31 +0000.