Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. indy-node
  4. ›
  5. CVE-2022-31020

CVE-2022-31020: Indy's NODE_UPGRADE transaction vulnerable to remote code execution

September 2, 2022 (updated November 18, 2024)

The pool-upgrade request handler in Indy-Node <=1.12.4 allows an improperly authenticated attacker to remotely execute code on nodes within the network.

Network operators are strongly encouraged to upgrade to the latest Indy-Node release >=1.12.5 as soon as possible.

References

  • github.com/advisories/GHSA-r6v9-p59m-gj2p
  • github.com/hyperledger/indy-node
  • github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5
  • github.com/hyperledger/indy-node/releases/tag/v1.12.5
  • github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p
  • github.com/pypa/advisory-database/tree/main/vulns/indy-node/PYSEC-2022-265.yaml
  • nvd.nist.gov/vuln/detail/CVE-2022-31020

Code Behaviors & Features

Detect and mitigate CVE-2022-31020 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.12.5rc1

Fixed versions

  • 1.12.5rc1

Solution

Upgrade to version 1.12.5rc1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

pypi/indy-node/CVE-2022-31020.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:33 +0000.