Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. gradio_pdf
  4. ›
  5. GHSA-4m3g-6r7g-jv4f

GHSA-4m3g-6r7g-jv4f: Arbitrary JavaScript execution due to using outdated libraries

June 5, 2024

gradio-pdf projects with dependencies on the pdf.js library are vulnerable to CVE-2024-4367, which allows arbitrary JavaScript execution.

References

  • github.com/advisories/GHSA-4m3g-6r7g-jv4f
  • github.com/freddyaboulton/gradio-pdf
  • github.com/freddyaboulton/gradio-pdf/commit/67edd0c625fae7b855186727ee9678297602ee45
  • github.com/freddyaboulton/gradio-pdf/security/advisories/GHSA-4m3g-6r7g-jv4f

Code Behaviors & Features

Detect and mitigate GHSA-4m3g-6r7g-jv4f with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.0.10

Fixed versions

  • 0.0.10

Solution

Upgrade to version 0.0.10 or above.

Impact 3.6 LOW

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/gradio_pdf/GHSA-4m3g-6r7g-jv4f.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:26 +0000.