Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. gradio
  4. ›
  5. CVE-2024-1540

CVE-2024-1540: Gradio's CI vulnerable to Command Injection

March 27, 2024

Previously, it was possible to exfiltrate secrets in Gradio’s CI, but this is now fixed.

References

  • github.com/advisories/GHSA-xcgp-r7r8-2hc9
  • github.com/gradio-app/gradio
  • github.com/gradio-app/gradio/commit/d56bb28df80d8db1f33e4acf4f6b2c4f87cb8b28
  • huntr.com/bounties/0e39e974-9a66-476f-91f5-3f37abb03d77
  • nvd.nist.gov/vuln/detail/CVE-2024-1540

Code Behaviors & Features

Detect and mitigate CVE-2024-1540 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.18.0

Fixed versions

  • 4.18.0

Solution

Upgrade to version 4.18.0 or above.

Impact 8.6 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')

Source file

pypi/gradio/CVE-2024-1540.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:31 +0000.