Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. gevent
  4. ›
  5. CVE-2023-41419

CVE-2023-41419: Gevent allows remote attacker to escalate privileges

September 25, 2023 (updated November 27, 2025)

An issue in Gevent before version 23.9.0 allows a remote attacker to escalate privileges via a crafted script to the WSGIServer component.

References

  • github.com/advisories/GHSA-x7m3-jprg-wc5g
  • github.com/gevent/gevent
  • github.com/gevent/gevent/commit/2f53c851eaf926767fbac62385615efd4886221c
  • github.com/gevent/gevent/issues/1989
  • github.com/pypa/advisory-database/tree/main/vulns/gevent/PYSEC-2023-177.yaml
  • lists.debian.org/debian-lts-announce/2025/11/msg00020.html
  • nvd.nist.gov/vuln/detail/CVE-2023-41419

Code Behaviors & Features

Detect and mitigate CVE-2023-41419 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 23.9.0

Fixed versions

  • 23.9.0

Solution

Upgrade to version 23.9.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

pypi/gevent/CVE-2023-41419.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:03 +0000.