Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. gerapy
  4. ›
  5. CVE-2021-44597

CVE-2021-44597: Incorrect Authorization

March 10, 2022 (updated July 12, 2022)

An Access Control vunerabiity exists in Gerapy v 0.9.7 via the spider parameter in project_configure function.

References

  • github.com/Gerapy/Gerapy/issues/219
  • nvd.nist.gov/vuln/detail/CVE-2021-44597

Code Behaviors & Features

Detect and mitigate CVE-2021-44597 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 0.9.7

Fixed versions

  • 0.9.8

Solution

Upgrade to version 0.9.8 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

pypi/gerapy/CVE-2021-44597.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:02 +0000.