Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. frappe
  4. ›
  5. CVE-2025-30217

CVE-2025-30217: Frappe has possibility of SQL injection due to improper validations

March 26, 2025 (updated October 31, 2025)

SQL injection could be achieved via a specially crafted request, which could allow malicious person to gain access to sensitive information.

References

  • github.com/advisories/GHSA-6phg-4wmq-h5h3
  • github.com/frappe/frappe
  • github.com/frappe/frappe/security/advisories/GHSA-6phg-4wmq-h5h3
  • nvd.nist.gov/vuln/detail/CVE-2025-30217

Code Behaviors & Features

Detect and mitigate CVE-2025-30217 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 14.93.2, all versions starting from 15.0.0 before 15.55.0

Fixed versions

  • 14.93.2
  • 15.55.0

Solution

Upgrade to versions 14.93.2, 15.55.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

Source file

pypi/frappe/CVE-2025-30217.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:27 +0000.