Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. frappe
  4. ›
  5. CVE-2025-30213

CVE-2025-30213: Frappe has Possibility of Remote Code Execution due to improper validation

March 25, 2025 (updated October 31, 2025)

A system user was able to create certain documents in a specific way that could lead to RCE.

References

  • github.com/advisories/GHSA-v342-4xr9-x3q3
  • github.com/frappe/frappe
  • github.com/frappe/frappe/security/advisories/GHSA-v342-4xr9-x3q3
  • nvd.nist.gov/vuln/detail/CVE-2025-30213

Code Behaviors & Features

Detect and mitigate CVE-2025-30213 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 14.91.0, all versions starting from 15.0.0 before 15.52.0

Fixed versions

  • 14.91.0
  • 15.52.0

Solution

Upgrade to versions 14.91.0, 15.52.0 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/frappe/CVE-2025-30213.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:22 +0000.