Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. fgr
  4. ›
  5. GHSA-879p-8gw4-mcpw

GHSA-879p-8gw4-mcpw: fgr Vulnerable to Insecure Default Variable Initialization

March 15, 2024

Impact

Any users whom would not desire a traceback to be included in their logs whenever an error is raised in their code will be affected.

If users have inadvertently created a scenario in their code that could cause a traceback to include sensitive information and a malicious entity gained access to their log stream, this could create an issue.

Patches

None yet… users will need to upgrade to 0.4.*

Workarounds

No particularly reasonable ones at present.

References

  • https://cwe.mitre.org/data/definitions/453.html
  • https://www.invicti.com/web-vulnerability-scanner/vulnerabilities/stack-trace-disclosure-python/

References

  • github.com/advisories/GHSA-879p-8gw4-mcpw
  • github.com/dan1hc/fgr
  • github.com/dan1hc/fgr/security/advisories/GHSA-879p-8gw4-mcpw

Code Behaviors & Features

Detect and mitigate GHSA-879p-8gw4-mcpw with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 0.3.2

Solution

Unfortunately, there is no solution available yet.

Impact 3.7 LOW

CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-453: Insecure Default Variable Initialization

Source file

pypi/fgr/GHSA-879p-8gw4-mcpw.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:22 +0000.