Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. feedparser
  4. ›
  5. CVE-2011-1156

CVE-2011-1156: feedparser denial of service vulnerability

July 23, 2018 (updated September 20, 2024)

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

References

  • bugzilla.novell.com/show_bug.cgi?id=680074
  • bugzilla.redhat.com/show_bug.cgi?id=684877
  • code.google.com/p/feedparser/issues/detail?id=91
  • github.com/advisories/GHSA-6h52-4vmh-8x4f
  • github.com/pypa/advisory-database/tree/main/vulns/feedparser/PYSEC-2011-19.yaml
  • nvd.nist.gov/vuln/detail/CVE-2011-1156
  • web.archive.org/web/20150523054015/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2011:082/?name=MDVSA-2011:082
  • web.archive.org/web/20210121212051/https://www.securityfocus.com/bid/46867

Code Behaviors & Features

Detect and mitigate CVE-2011-1156 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.1 before 5.0.1

Fixed versions

  • 5.0.1

Solution

Upgrade to version 5.0.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/feedparser/CVE-2011-1156.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:32 +0000.