Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. feedparser
  4. ›
  5. CVE-2009-5065

CVE-2009-5065: feedparser Cross-site Scripting vulnerability

May 2, 2022 (updated September 20, 2024)

Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0 allows remote attackers to inject arbitrary web script or HTML via vectors involving nested CDATA stanzas.

References

  • bugzilla.novell.com/show_bug.cgi?id=680074
  • bugzilla.redhat.com/show_bug.cgi?id=684877
  • github.com/advisories/GHSA-3mwg-gp5g-fv3q
  • github.com/kurtmckee/feedparser
  • github.com/pypa/advisory-database/tree/main/vulns/feedparser/PYSEC-2011-18.yaml
  • nvd.nist.gov/vuln/detail/CVE-2009-5065
  • web.archive.org/web/20200228153921/http://www.securityfocus.com/bid/47177
  • web.archive.org/web/20210329050642/http://www.mandriva.com/security/advisories?name=MDVSA-2011:082

Code Behaviors & Features

Detect and mitigate CVE-2009-5065 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.0

Fixed versions

  • 5.0

Solution

Upgrade to version 5.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/feedparser/CVE-2009-5065.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:42 +0000.