Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. fava
  4. ›
  5. CVE-2022-2589

CVE-2022-2589: Fava vulnerable to reflected cross-site scripting

August 2, 2022 (updated September 20, 2024)

Fava before 1.22.3 is vulnerable to reflected cross-site scripting due to improper validation on filter conversion.

References

  • github.com/advisories/GHSA-6hcj-qrw3-m66q
  • github.com/beancount/fava
  • github.com/beancount/fava/commit/68bbb6e39319deb35ab9f18d0b6aa9fa70472539
  • github.com/pypa/advisory-database/tree/main/vulns/fava/PYSEC-2022-246.yaml
  • huntr.dev/bounties/8705800d-cf2f-433d-9c3e-dbef6a3f7e08
  • nvd.nist.gov/vuln/detail/CVE-2022-2589

Code Behaviors & Features

Detect and mitigate CVE-2022-2589 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.22.3

Fixed versions

  • 1.22.3

Solution

Upgrade to version 1.22.3 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/fava/CVE-2022-2589.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:11 +0000.