Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. fastmcp
  4. ›
  5. CVE-2025-64340

CVE-2025-64340: FastMCP has a Command Injection vulnerability - Gemini CLI

March 31, 2026 (updated April 6, 2026)

Server names containing shell metacharacters (e.g., &) can cause command injection on Windows when passed to fastmcp install claude-code or fastmcp install gemini-cli. These install paths use subprocess.run() with a list argument, but on Windows the target CLIs often resolve to .cmd wrappers that are executed through cmd.exe, which interprets metacharacters in the flattened command string.

PoC:

from fastmcp import FastMCP

mcp = FastMCP(name="test&calc")

@mcp.tool
def roll_dice(n_dice: int) -> list[int]:
"""Roll `n_dice` 6-sided dice and return the results."""
return [random.randint(1, 6) for _ in range(n_dice)]
fastmcp install claude-code server.py   # or: fastmcp install gemini-cli server.py

On Windows, this opens Calculator via the &calc in the server name.

Impact: Arbitrary command execution with the privileges of the user running fastmcp install. Affects Windows hosts where the target CLI (one of claude, gemini) is installed as a .cmd wrapper. Does not affect macOS/Linux, and does not affect config-file-based install targets (cursor, goose, mcp-json).

Patched in #3522 by validating server names to reject shell metacharacters.

References

  • github.com/PrefectHQ/fastmcp
  • github.com/PrefectHQ/fastmcp/pull/3522
  • github.com/PrefectHQ/fastmcp/security/advisories/GHSA-m8x7-r2rg-vh5g
  • github.com/advisories/GHSA-m8x7-r2rg-vh5g
  • github.com/jlowin/fastmcp/security/advisories/GHSA-m8x7-r2rg-vh5g
  • nvd.nist.gov/vuln/detail/CVE-2025-64340

Code Behaviors & Features

Detect and mitigate CVE-2025-64340 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.2.0

Fixed versions

  • 3.2.0

Solution

Upgrade to version 3.2.0 or above.

Impact 6.7 MEDIUM

CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

pypi/fastmcp/CVE-2025-64340.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:26 +0000.