Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. edumfa
  4. ›
  5. GHSA-vhmj-5q9r-mm9g

GHSA-vhmj-5q9r-mm9g: BlastRADIUS also affects eduMFA

July 17, 2024

BlastRADIUS (see blastradius.fail for details) also affects eduMFA prior version 2.2.0, because the Message-Authenticator attributes were not checked.

References

  • github.com/advisories/GHSA-vhmj-5q9r-mm9g
  • github.com/eduMFA/eduMFA
  • github.com/eduMFA/eduMFA/commit/ad9d18be31e8a6f536c646dc037d945de33fac60
  • github.com/eduMFA/eduMFA/security/advisories/GHSA-vhmj-5q9r-mm9g
  • kb.cert.org/vuls/id/456537
  • nvd.nist.gov/vuln/detail/CVE-2024-3596

Code Behaviors & Features

Detect and mitigate GHSA-vhmj-5q9r-mm9g with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.2.0

Fixed versions

  • 2.2.0

Solution

Upgrade to version 2.2.0 or above.

Impact 6.8 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-924: Improper Enforcement of Message Integrity During Transmission in a Communication Channel

Source file

pypi/edumfa/GHSA-vhmj-5q9r-mm9g.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:23 +0000.