Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. dulwich
  4. ›
  5. CVE-2015-0838

CVE-2015-0838: Dulwich Buffer Overflow when handling pack files

May 17, 2022 (updated April 14, 2025)

Buffer overflow in the C implementation of the apply_delta function in _pack.c in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a crafted pack file.

References

  • github.com/advisories/GHSA-vjjf-3rvg-gv3v
  • github.com/jelmer/dulwich
  • github.com/pypa/advisory-database/tree/main/vulns/dulwich/PYSEC-2015-35.yaml
  • lists.launchpad.net/dulwich-users/msg00829.html
  • nvd.nist.gov/vuln/detail/CVE-2015-0838

Code Behaviors & Features

Detect and mitigate CVE-2015-0838 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.9.9

Fixed versions

  • 0.9.9

Solution

Upgrade to version 0.9.9 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-119: Improper Restriction of Operations within the Bounds of a Memory Buffer

Source file

pypi/dulwich/CVE-2015-0838.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:42 +0000.