Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Django
  4. ›
  5. CVE-2023-41164

CVE-2023-41164: Django Denial of service vulnerability in django.utils.encoding.uri_to_iri

November 3, 2023 (updated November 4, 2025)

In Django 3.2 before 3.2.21, 4.1 before 4.1.11, and 4.2 before 4.2.5, django.utils.encoding.uri_to_iri() is subject to a potential DoS (denial of service) attack via certain inputs with a very large number of Unicode characters.

References

  • docs.djangoproject.com/en/4.2/releases/security
  • github.com/advisories/GHSA-7h4p-27mh-hmrw
  • github.com/django/django
  • github.com/django/django/commit/6f030b1149bd8fa4ba90452e77cb3edc095ce54e
  • github.com/django/django/commit/9c51b4dcfa0cefcb48231f4d71cafa80821f87b9
  • github.com/django/django/commit/ba00bc5ec6a7eff5e08be438f7b5b0e9574e8ff0
  • github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2023-225.yaml
  • groups.google.com/forum/
  • groups.google.com/forum/
  • lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HJFRPUHDYJHBH3KYHSPGULQM4JN7BMSU
  • lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZQJOMNRMVPCN5WMIZ7YSX5LQ7IR2NY4D
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HJFRPUHDYJHBH3KYHSPGULQM4JN7BMSU
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZQJOMNRMVPCN5WMIZ7YSX5LQ7IR2NY4D
  • nvd.nist.gov/vuln/detail/CVE-2023-41164
  • security.netapp.com/advisory/ntap-20231214-0002
  • www.djangoproject.com/weblog/2023/sep/04/security-releases

Code Behaviors & Features

Detect and mitigate CVE-2023-41164 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.2 before 3.2.21, all versions starting from 4.1 before 4.1.11, all versions starting from 4.2 before 4.2.5

Fixed versions

  • 3.2.21
  • 4.1.11
  • 4.2.5

Solution

Upgrade to versions 3.2.21, 4.1.11, 4.2.5 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-1284: Improper Validation of Specified Quantity in Input
  • CWE-400: Uncontrolled Resource Consumption

Source file

pypi/Django/CVE-2023-41164.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:09 +0000.