Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Django
  4. ›
  5. CVE-2016-7401

CVE-2016-7401: Django CSRF Protection Bypass

May 14, 2022 (updated September 18, 2024)

The cookie parsing code in Django before 1.8.15 and 1.9.x before 1.9.10, when used on a site with Google Analytics, allows remote attackers to bypass an intended CSRF protection mechanism by setting arbitrary cookies.

References

  • github.com/advisories/GHSA-crhm-qpjc-cm64
  • github.com/django/django
  • github.com/django/django/commit/6118ab7d0676f0d622278e5be215f14fb5410b6a
  • github.com/django/django/commit/6fe846a8f08dc959003f298b5407e321c6fe3735
  • github.com/django/django/commit/d1bc980db1c0fffd6d60677e62f70beadb9fe64a
  • github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2016-3.yaml
  • nvd.nist.gov/vuln/detail/CVE-2016-7401
  • web.archive.org/web/20200227223637/http://www.securityfocus.com/bid/93182
  • web.archive.org/web/20210927195154/http://www.securitytracker.com/id/1036899
  • www.djangoproject.com/weblog/2016/sep/26/security-releases

Code Behaviors & Features

Detect and mitigate CVE-2016-7401 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.8.15, all versions starting from 1.9 before 1.9.10

Fixed versions

  • 1.8.15
  • 1.9.10

Solution

Upgrade to versions 1.8.15, 1.9.10 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Source file

pypi/Django/CVE-2016-7401.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:02 +0000.