Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Django
  4. ›
  5. CVE-2016-6186

CVE-2016-6186: Django Cross-site scripting Vulnerability

May 14, 2022 (updated September 17, 2024)

Cross-site scripting (XSS) vulnerability in the dismissChangeRelatedObjectPopup function in contrib/admin/static/admin/js/admin/RelatedObjectLookups.js in Django before 1.8.14, 1.9.x before 1.9.8, and 1.10.x before 1.10rc1 allows remote attackers to inject arbitrary web script or HTML via vectors involving unsafe usage of Element.innerHTML.

References

  • github.com/advisories/GHSA-c8c8-9472-w52h
  • github.com/django/django
  • github.com/django/django/commit/6fa150b2f8b601668083042324c4add534143cb1
  • github.com/django/django/commit/d03bf6fe4e9bf5b07de62c1a271c4b41a7d3d158
  • github.com/django/django/commit/f68e5a99164867ab0e071a936470958ed867479d
  • github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2016-2.yaml
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DMLLFAUT4J4IP4P2KI4NOVWRMHA22WUJ
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KHHPN6MISX5I6UTXQHYLPTLEEUE6WDXW
  • nvd.nist.gov/vuln/detail/CVE-2016-6186
  • web.archive.org/web/20201022155237/http://www.securityfocus.com/archive/1/538947/100/0/threaded
  • web.archive.org/web/20210123154652/http://www.securityfocus.com/bid/92058
  • web.archive.org/web/20211204042848/http://www.securitytracker.com/id/1036338
  • www.djangoproject.com/weblog/2016/jul/18/security-releases
  • www.exploit-db.com/exploits/40129

Code Behaviors & Features

Detect and mitigate CVE-2016-6186 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.10a1 before 1.10rc1, all versions before 1.8.14, all versions starting from 1.9 before 1.9.8

Fixed versions

  • 1.8.14
  • 1.9.8
  • 1.10rc1

Solution

Upgrade to versions 1.10rc1, 1.8.14, 1.9.8 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/Django/CVE-2016-6186.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:41 +0000.