Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Django
  4. ›
  5. CVE-2015-0220

CVE-2015-0220: Django Cross-site Scripting Vulnerability

May 17, 2022 (updated September 18, 2024)

The django.util.http.is_safe_url function in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 does not properly handle leading whitespaces, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted URL, related to redirect URLs, as demonstrated by a \njavascript: URL.

References

  • github.com/advisories/GHSA-gv98-g628-m9x5
  • github.com/django/django
  • github.com/django/django/blob/4555a823fd57e261e1b19c778429473256c8ea08/docs/releases/1.4.18.txt
  • github.com/django/django/commit/4c241f1b710da6419d9dca160e80b23b82db7758
  • github.com/django/django/commit/72e0b033662faa11bb7f516f18a132728aa0ae28
  • github.com/django/django/commit/de67dedc771ad2edec15c1d00c083a1a084e1e89
  • github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2015-5.yaml
  • nvd.nist.gov/vuln/detail/CVE-2015-0220
  • web.archive.org/web/20150128111656/http://secunia.com/advisories/62285
  • web.archive.org/web/20150523054951/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2015:109/?name=MDVSA-2015:109
  • web.archive.org/web/20150523054953/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2015:036/?name=MDVSA-2015:036
  • web.archive.org/web/20151104201446/http://secunia.com/advisories/62718
  • www.djangoproject.com/weblog/2015/jan/13/security

Code Behaviors & Features

Detect and mitigate CVE-2015-0220 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.4.18, all versions starting from 1.6 before 1.6.10, all versions starting from 1.7 before 1.7.3

Fixed versions

  • 1.4.18
  • 1.6.10
  • 1.7.3

Solution

Upgrade to versions 1.4.18, 1.6.10, 1.7.3 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/Django/CVE-2015-0220.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:24 +0000.