Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. django-helpdesk
  4. ›
  5. CVE-2021-3994

CVE-2021-3994: django-helpdesk is vulnerable to Cross-site Scripting

December 3, 2021 (updated September 16, 2024)

django-helpdesk is vulnerable to Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’).

References

  • github.com/advisories/GHSA-2v5j-q74q-r53f
  • github.com/django-helpdesk/django-helpdesk
  • github.com/django-helpdesk/django-helpdesk/commit/a22eb0673fe0b7784f99c6b5fd343b64a6700f06
  • github.com/django-helpdesk/django-helpdesk/releases/tag/0.3.2
  • github.com/pypa/advisory-database/tree/main/vulns/django-helpdesk/PYSEC-2021-438.yaml
  • huntr.dev/bounties/be7f211d-4bfd-44fd-91e8-682329906fbd
  • nvd.nist.gov/vuln/detail/CVE-2021-3994

Code Behaviors & Features

Detect and mitigate CVE-2021-3994 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.3.2

Fixed versions

  • 0.3.2

Solution

Upgrade to version 0.3.2 or above.

Impact 9.6 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/django-helpdesk/CVE-2021-3994.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:19 +0000.