Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. dbt-core
  4. ›
  5. GHSA-p72q-h37j-3hq7

GHSA-p72q-h37j-3hq7: dbt uses a SQLparse version with a high vulnerability

April 22, 2024

Using a version of sqlparse that has a security vulnerability and no way to update in current version of dbt core. Snyk recommends using sqlparse==0.5 but this causes a conflict with dbt. Snyk states the issues is a recursion error: SNYK-PYTHON-SQLPARSE-6615674.

References

  • github.com/advisories/GHSA-p72q-h37j-3hq7
  • github.com/andialbrecht/sqlparse/security/advisories/GHSA-2m57-hf25-phgg
  • github.com/dbt-labs/dbt-core
  • github.com/dbt-labs/dbt-core/security/advisories/GHSA-p72q-h37j-3hq7
  • security.snyk.io/vuln/SNYK-PYTHON-SQLPARSE-6615674

Code Behaviors & Features

Detect and mitigate GHSA-p72q-h37j-3hq7 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.6.0 before 1.6.13, all versions starting from 1.7.0 before 1.7.13

Fixed versions

  • 1.6.13
  • 1.7.13

Solution

Upgrade to versions 1.6.13, 1.7.13 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-673: External Influence of Sphere Definition

Source file

pypi/dbt-core/GHSA-p72q-h37j-3hq7.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:07 +0000.