Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. codechecker
  4. ›
  5. CVE-2025-40843

CVE-2025-40843: CodeChecker has a buffer overflow in the log command

September 22, 2025 (updated June 5, 2026)

CodeChecker versions up to 6.26.1 contain a buffer overflow vulnerability in the internal ldlogger library, which is executed by the CodeChecker log command.

References

  • github.com/Ericsson/codechecker/commit/4122eb1b43d00c880e4f0747d2ca0a674feb7a50
  • github.com/Ericsson/codechecker/security/advisories/GHSA-5xf2-f6ch-6p8r
  • github.com/advisories/GHSA-5xf2-f6ch-6p8r
  • github.com/pypa/advisory-database/tree/main/vulns/codechecker/PYSEC-2025-100.yaml
  • nvd.nist.gov/vuln/detail/CVE-2025-40843

Code Behaviors & Features

Detect and mitigate CVE-2025-40843 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 6.26.2

Fixed versions

  • 6.26.2

Solution

Upgrade to version 6.26.2 or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-121: Stack-based Buffer Overflow

Source file

pypi/codechecker/CVE-2025-40843.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:03 +0000.