Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Cobbler
  4. ›
  5. CVE-2021-45083

CVE-2021-45083: Incorrect Default Permissions in Cobbler

February 21, 2022 (updated September 13, 2024)

An issue was discovered in Cobbler before 3.3.1. Files in /etc/cobbler are world readable. Two of those files contain some sensitive information that can be exposed to a local user who has non-privileged access to the server. The users.digest file contains the sha2-512 digest of users in a Cobbler local installation. In the case of an easy-to-guess password, it’s trivial to obtain the plaintext string. The settings.yaml file contains secrets such as the hashed default password.

References

  • bugzilla.suse.com/show_bug.cgi?id=1193671
  • github.com/advisories/GHSA-5946-mpw5-pqxx
  • github.com/cobbler/cobbler
  • github.com/cobbler/cobbler/commit/10b2112db83fedfc391e900edfedc2b4e507d3f7
  • github.com/cobbler/cobbler/pull/2945
  • github.com/cobbler/cobbler/releases
  • github.com/cobbler/cobbler/releases/tag/v3.3.1
  • github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2022-38.yaml
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TEJN7CPW6YCHBFQPFZKGA6AVA6T5NPIW
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/Z5CSXQE7Q4TVDQJKFYBO4XDH3BZ7BLAR
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZCXMOUW4DH4DYWIJN44SMSU6R3CZDZBE
  • nvd.nist.gov/vuln/detail/CVE-2021-45083
  • www.openwall.com/lists/oss-security/2022/02/18/3

Code Behaviors & Features

Detect and mitigate CVE-2021-45083 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.3.1

Fixed versions

  • 3.3.1

Solution

Upgrade to version 3.3.1 or above.

Impact 7.1 HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-276: Incorrect Default Permissions

Source file

pypi/Cobbler/CVE-2021-45083.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:12 +0000.