Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Cobbler
  4. ›
  5. CVE-2021-40325

CVE-2021-40325: Cobbler before 3.3.0 allows authorization bypass for modification of settings.

October 5, 2021 (updated September 13, 2024)

Cobbler before 3.3.0 allows authorization bypass for modification of settings.

References

  • github.com/advisories/GHSA-cr3f-r24j-3chw
  • github.com/cobbler/cobbler
  • github.com/cobbler/cobbler/commit/d8f60bbf14a838c8c8a1dba98086b223e35fe70a
  • github.com/cobbler/cobbler/releases/tag/v3.3.0
  • github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2021-375.yaml
  • nvd.nist.gov/vuln/detail/CVE-2021-40325

Code Behaviors & Features

Detect and mitigate CVE-2021-40325 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.3.0

Fixed versions

  • 3.3.0

Solution

Upgrade to version 3.3.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

pypi/Cobbler/CVE-2021-40325.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:35 +0000.