Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. Cobbler
  4. ›
  5. CVE-2018-1000226

CVE-2018-1000226: Cobbler Improper Validation of Security Tokens

May 13, 2022 (updated October 27, 2026)

Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via “network connectivity”. Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.

References

  • github.com/advisories/GHSA-f88q-22g8-frcg
  • github.com/cobbler/cobbler/issues/1916
  • github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2026-315.yaml
  • movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api
  • nvd.nist.gov/vuln/detail/CVE-2018-1000226
  • pypi.org/project/cobbler

Code Behaviors & Features

Detect and mitigate CVE-2018-1000226 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.0.0

Fixed versions

  • 3.0.0

Solution

Upgrade to version 3.0.0 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-732: Incorrect Permission Assignment for Critical Resource

Source file

pypi/Cobbler/CVE-2018-1000226.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:37 +0000.