Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ckan
  4. ›
  5. CVE-2024-41675

CVE-2024-41675: CKAN has Cross-site Scripting vector in the Datatables view plugin

August 21, 2024

The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector.

References

  • github.com/advisories/GHSA-r3jc-vhf4-6v32
  • github.com/ckan/ckan
  • github.com/ckan/ckan/commit/9e89ce8220ab1445e0bd85a67994a51d9d3d2688
  • github.com/ckan/ckan/commit/d7dfe8c427b1c63c75d788a609f3b7d7620a25a1
  • github.com/ckan/ckan/security/advisories/GHSA-r3jc-vhf4-6v32
  • nvd.nist.gov/vuln/detail/CVE-2024-41675

Code Behaviors & Features

Detect and mitigate CVE-2024-41675 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.7.0 before 2.10.5

Fixed versions

  • 2.10.5

Solution

Upgrade to version 2.10.5 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/ckan/CVE-2024-41675.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:43 +0000.