Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. chainlit
  4. ›
  5. CVE-2025-68492

CVE-2025-68492: Chainlit contains an authorization bypass vulnerability

January 14, 2026

Chainlit versions prior to 2.8.5 contain an authorization bypass through user-controlled key vulnerability. If this vulnerability is exploited, threads may be viewed or thread ownership may be obtained by an attacker who can log in to the product.

References

  • github.com/Chainlit/chainlit
  • github.com/Chainlit/chainlit/commit/8f1153db439eca58ae5c50c8276ba6fdd311448e
  • github.com/Chainlit/chainlit/pull/2637
  • github.com/Chainlit/chainlit/releases
  • github.com/Chainlit/chainlit/releases/tag/2.8.5
  • github.com/advisories/GHSA-v492-6xx2-p57g
  • jvn.jp/en/jp/JVN34964581
  • nvd.nist.gov/vuln/detail/CVE-2025-68492

Code Behaviors & Features

Detect and mitigate CVE-2025-68492 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.8.5

Fixed versions

  • 2.8.5

Solution

Upgrade to version 2.8.5 or above.

Impact 4.2 MEDIUM

CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-639: Authorization Bypass Through User-Controlled Key

Source file

pypi/chainlit/CVE-2025-68492.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.