Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. cfscrape
  4. ›
  5. CVE-2017-7235

CVE-2017-7235: cfscrape Improper Input Validation vulnerability

July 13, 2018 (updated September 13, 2024)

An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.

References

  • github.com/Anorov/cloudflare-scrape
  • github.com/Anorov/cloudflare-scrape/issues/97
  • github.com/Anorov/cloudflare-scrape/releases/tag/1.8.0
  • github.com/advisories/GHSA-5mc5-5j6c-qmf9
  • github.com/pypa/advisory-database/tree/main/vulns/cfscrape/PYSEC-2017-7.yaml
  • nvd.nist.gov/vuln/detail/CVE-2017-7235
  • web.archive.org/web/20170701161512/http://www.securityfocus.com/bid/97191

Code Behaviors & Features

Detect and mitigate CVE-2017-7235 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.6.6 before 1.8.0

Fixed versions

  • 1.8.0

Solution

Upgrade to version 1.8.0 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/cfscrape/CVE-2017-7235.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.