Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. calibreweb
  4. ›
  5. CVE-2022-0352

CVE-2022-0352: Cross-site Scripting in calibreweb

January 29, 2022 (updated November 19, 2024)

calibreweb prior to version 0.6.16 contains a cross-site scripting vulnerability.

References

  • github.com/advisories/GHSA-h56g-v4vp-q9q6
  • github.com/janeczku/calibre-web
  • github.com/janeczku/calibre-web/commit/6bf07539788004513c3692c074ebc7ba4ce005e1
  • github.com/pypa/advisory-database/tree/main/vulns/calibreweb/PYSEC-2022-18.yaml
  • huntr.dev/bounties/a577ff17-2ded-4c41-84ae-6ac02440f717
  • nvd.nist.gov/vuln/detail/CVE-2022-0352

Code Behaviors & Features

Detect and mitigate CVE-2022-0352 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.6.16

Fixed versions

  • 0.6.16

Solution

Upgrade to version 0.6.16 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/calibreweb/CVE-2022-0352.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:18 +0000.