Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. cadwyn
  4. ›
  5. CVE-2025-53528

CVE-2025-53528: Cadwyn vulnerable to XSS on the docs page

July 21, 2025 (updated July 23, 2025)

The version parameter of the /docs endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack.

References

  • github.com/advisories/GHSA-2gxp-6r36-m97r
  • github.com/zmievsa/cadwyn
  • github.com/zmievsa/cadwyn/blob/5.4.3/CHANGELOG.md
  • github.com/zmievsa/cadwyn/commit/b424ecd57cd8dabbc8fe39b8f8ccafea629c7728
  • github.com/zmievsa/cadwyn/security/advisories/GHSA-2gxp-6r36-m97r
  • nvd.nist.gov/vuln/detail/CVE-2025-53528

Code Behaviors & Features

Detect and mitigate CVE-2025-53528 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.4.3

Fixed versions

  • 5.4.3

Solution

Upgrade to version 5.4.3 or above.

Impact 7.6 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/cadwyn/CVE-2025-53528.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:04 +0000.