Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. brotli
  4. ›
  5. GHSA-9v8h-qqgm-4m35

GHSA-9v8h-qqgm-4m35: Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

October 22, 2026 (updated November 3, 2026)

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.

Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

References

  • broccoli2shell.com/
  • cert-portal.siemens.com/productcert/html/ssa-045512.html
  • cert-portal.siemens.com/productcert/html/ssa-443410.html
  • cert-portal.siemens.com/productcert/html/ssa-898633.html
  • ellio.tech/en/blog/node2shell-cve-2026-111497-rce-on-stock-nodejs-builds
  • github.com/advisories/GHSA-9v8h-qqgm-4m35
  • github.com/andybalholm/brotli/releases/tag/v1.2.7
  • github.com/dotnet/announcements/issues/494
  • github.com/google/brotli/commit/0ed4268a4401abcb4472096340477cf4af7d1a2b
  • github.com/google/brotli/commit/50a9b70a4d5e1443fc40927952276b68fffa83a0
  • github.com/google/brotli/commit/b418fa81c48262a86a95332b0bc6d62c30aa78b6
  • github.com/google/brotli/commit/da9806362874b9bd4b552a3af360b5d6347beb12
  • github.com/google/brotli/releases/tag/v1.0.10
  • github.com/google/brotli/releases/tag/v1.1.1
  • github.com/google/brotli/releases/tag/v1.2.1
  • github.com/pypa/advisory-database/tree/main/vulns/brotli/PYSEC-2026-4322.yaml
  • github.com/pypa/advisory-database/tree/main/vulns/brotlicffi/PYSEC-2026-4323.yaml
  • lists.debian.org/debian-lts-announce/2026/10/msg00049.html
  • nodejs.org/en/blog/vulnerability/october-2026-security-releases
  • nodejs.org/en/blog/vulnerability/october-2026-security-releases
  • nvd.nist.gov/vuln/detail/CVE-2026-111497
  • opensourcemalware.com/blog/node2shell-affects-python
  • patchtheplanet.org/brotli
  • pypi.org/project/Brotli
  • pypi.org/project/brotlicffi
  • www.aikido.dev/blog/node2shell-nodejs-brotli-rce-cve-2026-111497
  • www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-111497
  • www.cve.org/CVERecord?id=CVE-2026-111497

Code Behaviors & Features

Detect and mitigate GHSA-9v8h-qqgm-4m35 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.0.3 before 1.2.1

Fixed versions

  • 1.2.1

Solution

Upgrade to version 1.2.1 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-252: Unchecked Return Value

Source file

pypi/brotli/GHSA-9v8h-qqgm-4m35.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:18 +0000.