Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. bodhi
  4. ›
  5. CVE-2017-1002152

CVE-2017-1002152: Cross-site Scripting

January 10, 2019 (updated October 9, 2019)

Bodhi is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.

References

  • github.com/fedora-infra/bodhi/issues/1740
  • nvd.nist.gov/vuln/detail/CVE-2017-1002152

Code Behaviors & Features

Detect and mitigate CVE-2017-1002152 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.9.0

Fixed versions

  • 3.3.0

Solution

Upgrade to version 3.3.0 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/bodhi/CVE-2017-1002152.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:52 +0000.