Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. black
  4. ›
  5. CVE-2026-114134

CVE-2026-114134: Black: GitHub Action installs unvalidated required-version from pyproject.toml

October 22, 2026

The GitHub Action bundled with Black can read the version from tool.black.required-version if use_pyproject is set to True. This version is not validated and therefore can be used to execute untrusted code in the context of a victim’s repository.

References

  • github.com/advisories/GHSA-cg8m-r9f2-5wm2
  • github.com/psf/black/commit/ac1f71563aeccf73cf13ece00f231d9d6c66a514
  • github.com/psf/black/pull/5510
  • github.com/psf/black/releases/tag/26.10.1
  • github.com/psf/black/security/advisories/GHSA-cg8m-r9f2-5wm2
  • nvd.nist.gov/vuln/detail/CVE-2026-114134

Code Behaviors & Features

Detect and mitigate CVE-2026-114134 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 26.10.1

Fixed versions

  • 26.10.1

Solution

Upgrade to version 26.10.1 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-829: Inclusion of Functionality from Untrusted Control Sphere

Source file

pypi/black/CVE-2026-114134.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:43 +0000.