Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. beginner
  4. ›
  5. CVE-2022-33004

CVE-2022-33004: Inclusion of Functionality from Untrusted Control Sphere (Malicious Dependency)

June 24, 2022 (updated July 5, 2022)

The Beginner package in PyPI v0.0.2 to v0.0.4 was discovered to contain a code execution backdoor via the request package. This vulnerability allows attackers to access sensitive user information and digital currency keys, as well as escalate privileges.

References

  • pypi.doubanio.com/simple/request
  • github.com/Dreambuilder4028/coder/issues/1
  • nvd.nist.gov/vuln/detail/CVE-2022-33004
  • pypi.org/project/beginner/

Code Behaviors & Features

Detect and mitigate CVE-2022-33004 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.0.2 up to 0.0.4

Fixed versions

  • 0.0.5

Solution

Upgrade to version 0.0.5 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-829: Inclusion of Functionality from Untrusted Control Sphere

Source file

pypi/beginner/CVE-2022-33004.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.