Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-superset
  4. ›
  5. CVE-2025-55673

CVE-2025-55673: Apache Superset data query improperly discloses database schema information to low-privileged guest user

August 14, 2025 (updated November 10, 2025)

When a guest user accesses a chart in Apache Superset, the API response from the /chart/data endpoint includes a query field in its payload. This field contains the underlying query, which improperly discloses database schema information, such as table names, to the low-privileged guest user.

This issue affects Apache Superset: before 4.1.3.

Users are recommended to upgrade to version 4.1.3, which fixes the issue.

References

  • github.com/advisories/GHSA-9g5x-mm39-wg9r
  • github.com/apache/superset
  • lists.apache.org/thread/h2hw756wk4sj4z49blvzkr5fntl9hlf8
  • nvd.nist.gov/vuln/detail/CVE-2025-55673

Code Behaviors & Features

Detect and mitigate CVE-2025-55673 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.1.3.post1

Fixed versions

  • 4.1.3.post1

Solution

Upgrade to version 4.1.3.post1 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

pypi/apache-superset/CVE-2025-55673.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:45 +0000.