Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-superset
  4. ›
  5. CVE-2024-28148

CVE-2024-28148: Apache Superset Incorrect Authorization vulnerability

May 7, 2024

An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request. This issue affects Apache Superset before 4.0.0.

Users are recommended to upgrade to version 4.0.0, which fixes the issue.

References

  • github.com/advisories/GHSA-299q-3p96-5898
  • github.com/apache/superset
  • lists.apache.org/thread/n27wlbd05oc6bgjh28d5pxzsrrph8dgo
  • nvd.nist.gov/vuln/detail/CVE-2024-28148

Code Behaviors & Features

Detect and mitigate CVE-2024-28148 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.0.0

Fixed versions

  • 4.0.0

Solution

Upgrade to version 4.0.0 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

pypi/apache-superset/CVE-2024-28148.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:50 +0000.