CVE-2023-49736: Apache Superset SQL injection vulnerability
(updated )
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.3, from 3.0.0 before 3.0.2.
Users are recommended to upgrade to version 2.1.3 or 3.0.2, which fixes the issue.
References
- github.com/advisories/GHSA-jfxj-xf67-x723
- github.com/apache/superset
- github.com/apache/superset/commit/1d403dab9822a8cee6108669c53e53fad881c751
- github.com/apache/superset/commit/34101594e284ab3acce692f41aff7759ccb4bf1d
- github.com/apache/superset/pull/25779
- lists.apache.org/thread/1kf481bgs3451qcz6hfhobs7xvhp8n1p
- nvd.nist.gov/vuln/detail/CVE-2023-49736
Code Behaviors & Features
Detect and mitigate CVE-2023-49736 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →